Posts

Showing posts from December, 2008

First Snowfall with our Yukon XL Denali

Image
Denali-snow2
Originally uploaded by istargazer. We finally got snow today. We've had unusually cold temperatures this past week, but wasn't until last night and today where we got enough snow to really mean anything. That gave me the opportunity to try out our 2007 GMC Yukon XL Denali.


I have to say, I was quite impressed with the way the Denali's AWD handled itself in the snow. We've been having unusually cold temps the past week--tonight it's going to drop to around -9° C (about 16° F)--and we received about 4-5 inches of snow through the night and during the day. It was the first snowfall of the season.

Coming from my 2006 Subaru Impreza WRX STI that had AWD, no traction control and was super fun, I was a little worried that the nanny on the Yukon would be too intrusive. Our 2003 Toyota Sequoia had a button to turn off the traction control, but it never really turned off completely--it was a total fun-killer.

I tried the Yukon with and without traction control on …

Baby Enzo

Image
Well, the reason why we bought our Denali arrived yesterday:

Baby Enzo, originally uploaded by istargazer. Specs:
Gender: maleWeight: 7 lb 0 oz.Length: 19.5 inches In-service date: 4 December 2008
Build date: classified
Production number: 005


Mom and baby are doing fine :0)

VW R32: Disappearing Coolant

A couple years ago my R's coolant warning light went off. I had it checked and the dealership couldn't find any leaks. Huh. I topped it off and everything was fine... until this weekend.

Click below the fold for more.

I'd just come back from an 830+ mile round-trip drive to Canada and back. After reaching home I popped the hood and to my shock the engine coolant level was 2 inches or so lower than normal, right at the "min level" mark. The engine was warm, too, which is when I always check the coolant.

No one could check my R that day, so the coolant was topped up to 1-2 inches above the "max level" mark. The next morning, with the engine cold, the coolant level had dropped back to the "min level" mark, where it stayed until I took it to the dealer the following morning.

The dealership put the coolant system under pressure (15 psi) for 40 minutes and couldn't find any leaks. Eh?

What the heck? Anywhoo, the coolant has been topped of…